Home | History | Annotate | Download | only in gles11

Lines Matching refs:GLfloat

63 void glGetFloatv ( GLenum pname, GLfloat *params )

74 void glGetTexParameterfv ( GLenum target, GLenum pname, GLfloat *params )
76 void glGetUniformfv ( GLuint program, GLint location, GLfloat *params )
79 void glGetVertexAttribfv ( GLuint index, GLenum pname, GLfloat *params )
90 void glLineWidth ( GLfloat width )
93 void glPolygonOffset ( GLfloat factor, GLfloat units )
108 void glTexParameterf ( GLenum target, GLenum pname, GLfloat param )
109 void glTexParameterfv ( GLenum target, GLenum pname, const GLfloat *params )
113 void glUniform1f ( GLint location, GLfloat x )
114 void glUniform1fv ( GLint location, GLsizei count, const GLfloat *v )
117 void glUniform2f ( GLint location, GLfloat x, GLfloat y )
118 void glUniform2fv ( GLint location, GLsizei count, const GLfloat *v )
121 void glUniform3f ( GLint location, GLfloat x, GLfloat y, GLfloat z )
122 void glUniform3fv ( GLint location, GLsizei count, const GLfloat *v )
125 void glUniform4f ( GLint location, GLfloat x, GLfloat y, GLfloat z, GLfloat w )
126 void glUniform4fv ( GLint location, GLsizei count, const GLfloat *v )
129 void glUniformMatrix2fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
130 void glUniformMatrix3fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
131 void glUniformMatrix4fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
134 void glVertexAttrib1f ( GLuint indx, GLfloat x )
135 void glVertexAttrib1fv ( GLuint indx, const GLfloat *values )
136 void glVertexAttrib2f ( GLuint indx, GLfloat x, GLfloat y )
137 void glVertexAttrib2fv ( GLuint indx, const GLfloat *values )
138 void glVertexAttrib3f ( GLuint indx, GLfloat x, GLfloat y, GLfloat z )
139 void glVertexAttrib3fv ( GLuint indx, const GLfloat *values )
140 void glVertexAttrib4f ( GLuint indx, GLfloat x, GLfloat y, GLfloat z, GLfloat w )
141 void glVertexAttrib4fv ( GLuint indx, const GLfloat *values )