Home | History | Annotate | Download | only in gles11

Lines Matching refs:GLuint

2 void glAttachShader ( GLuint program, GLuint shader )

3 void glBindAttribLocation ( GLuint program, GLuint index, const char *name )
4 void glBindBuffer ( GLenum target, GLuint buffer )
5 void glBindFramebuffer ( GLenum target, GLuint framebuffer )
6 void glBindRenderbuffer ( GLenum target, GLuint renderbuffer )
7 void glBindTexture ( GLenum target, GLuint texture )
21 void glCompileShader ( GLuint shader )
26 GLuint glCreateProgram ( void )
27 GLuint glCreateShader ( GLenum type )
29 void glDeleteBuffers ( GLsizei n, const GLuint *buffers )
30 void glDeleteFramebuffers ( GLsizei n, const GLuint *framebuffers )
31 void glDeleteProgram ( GLuint program )
32 void glDeleteRenderbuffers ( GLsizei n, const GLuint *renderbuffers )
33 void glDeleteShader ( GLuint shader )
34 void glDeleteTextures ( GLsizei n, const GLuint *textures )
38 void glDetachShader ( GLuint program, GLuint shader )
40 void glDisableVertexAttribArray ( GLuint index )
45 void glEnableVertexAttribArray ( GLuint index )
48 void glFramebufferRenderbuffer ( GLenum target, GLenum attachment, GLenum renderbuffertarget, GLuint renderbuffer )
49 void glFramebufferTexture2D ( GLenum target, GLenum attachment, GLenum textarget, GLuint texture, GLint level )
51 void glGenBuffers ( GLsizei n, GLuint *buffers )
53 void glGenFramebuffers ( GLsizei n, GLuint *framebuffers )
54 void glGenRenderbuffers ( GLsizei n, GLuint *renderbuffers )
55 void glGenTextures ( GLsizei n, GLuint *textures )
56 void glGetActiveAttrib ( GLuint program, GLuint index, GLsizei bufsize, GLsizei *length, GLint *size, GLenum *type, char *name )
57 void glGetActiveUniform ( GLuint program, GLuint index, GLsizei bufsize, GLsizei *length, GLint *size, GLenum *type, char *name )
58 void glGetAttachedShaders ( GLuint program, GLsizei maxcount, GLsizei *count, GLuint *shaders )
59 int glGetAttribLocation ( GLuint program, const char *name )
66 void glGetProgramiv ( GLuint program, GLenum pname, GLint *params )
67 void glGetProgramInfoLog ( GLuint program, GLsizei bufsize, GLsizei *length, char *infolog )
69 void glGetShaderiv ( GLuint shader, GLenum pname, GLint *params )
70 void glGetShaderInfoLog ( GLuint shader, GLsizei bufsize, GLsizei *length, char *infolog )
72 void glGetShaderSource ( GLuint shader, GLsizei bufsize, GLsizei *length, char *source )
76 void glGetUniformfv ( GLuint program, GLint location, GLfloat *params )
77 void glGetUniformiv ( GLuint program, GLint location, GLint *params )
78 int glGetUniformLocation ( GLuint program, const char *name )
79 void glGetVertexAttribfv ( GLuint index, GLenum pname, GLfloat *params )
80 void glGetVertexAttribiv ( GLuint index, GLenum pname, GLint *params )
81 // void glGetVertexAttribPointerv ( GLuint index, GLenum pname, void **pointer )
83 GLboolean glIsBuffer ( GLuint buffer )
85 GLboolean glIsFramebuffer ( GLuint framebuffer )
86 GLboolean glIsProgram ( GLuint program )
87 GLboolean glIsRenderbuffer ( GLuint renderbuffer )
88 GLboolean glIsShader ( GLuint shader )
89 GLboolean glIsTexture ( GLuint texture )
91 void glLinkProgram ( GLuint program )
99 void glShaderBinary ( GLsizei n, const GLuint *shaders, GLenum binaryformat, const GLvoid *binary, GLsizei length )
100 void glShaderSource ( GLuint shader )
101 void glStencilFunc ( GLenum func, GLint ref, GLuint mask )
102 void glStencilFuncSeparate ( GLenum face, GLenum func, GLint ref, GLuint mask )
103 void glStencilMask ( GLuint mask )
104 void glStencilMaskSeparate ( GLenum face, GLuint mask )
132 void glUseProgram ( GLuint program )
133 void glValidateProgram ( GLuint program )
134 void glVertexAttrib1f ( GLuint indx, GLfloat x )
135 void glVertexAttrib1fv ( GLuint indx, const GLfloat *values )
136 void glVertexAttrib2f ( GLuint indx, GLfloat x, GLfloat y )
137 void glVertexAttrib2fv ( GLuint indx, const GLfloat *values )
138 void glVertexAttrib3f ( GLuint indx, GLfloat x, GLfloat y, GLfloat z )
139 void glVertexAttrib3fv ( GLuint indx, const GLfloat *values )
140 void glVertexAttrib4f ( GLuint indx, GLfloat x, GLfloat y, GLfloat z, GLfloat w )
141 void glVertexAttrib4fv ( GLuint indx, const GLfloat *values )
142 void glVertexAttribPointer ( GLuint indx, GLint size, GLenum type, GLboolean normalized, GLsizei stride, GLint offset )
143 void glVertexAttribPointer ( GLuint indx, GLint size, GLenum type, GLboolean normalized, GLsizei stride, const GLvoid *ptr )