Lines Matching full:inode
23 fallocated() beyond an inode's i_size.
41 * Fix flex_bg inode table placement algorithm used by mke2fs for
71 when huge_file file system feature is set, but the inode does not
107 ones for multiple bad block group checksums, or when an inode
109 * Fix e2fsck to handle moving inode tables in FLEX_BG filesystems more
130 which prints detailed information about an inode's extent tree.
176 uninitalized data into the portion of the inode beyond the first 128
217 * e2fsck will no longer abort a preen operation if an inode's
222 use in the unused portion of the block group's inode table.
230 * Fix a bug in e2fsck which could cause it to crash if an inode has a
231 corrupt extent header, and the user declines to clear the inode.
306 * Speed up tune2fs's inode resizing code so it is no longer vastly
336 moved. In addition, blocks and inode table blocks were not being
346 * tune2fs will not allow changing the inode size for filesystems that
348 the each block group's portion inode table is located in its own
365 * Fix e2fsck so it prints the correct inode number for uinit_bg
475 with a newline for pass 4 (when the inode references are updated).
498 * Optimize inode table allocation in mke2fs for flex_bg filesystems.
526 cause it to relocate inode tables, causing more damage to the
541 the bitmaps and inode tables.
576 larger inode sizes so the user can take full advantage of ext4)
590 attributes stored in the inode.
652 with in-inode extended attributes.
669 * Fixed mke2fs man page to document new default inode size.
747 * E2fsck now optimizes non-htree directories by sorting them by inode
761 * Allow a user to undelete an inode with linking to a destination
841 allocating inode tables for some relatively rare odd disk sizes.
894 journal inode was cleared to due being corrupt
896 this is written out to the journal inode
897 * Make e2fsck check all of the blocks in the journal inode for validity
1021 * Allow the default inode size to be specified in mke2fs.conf
1034 not containing a resize inode. (Closes: #380548)
1076 * Speed up mke2fs and e2fsck by writing inode and block bitmaps in one pass
1211 when setting certain inode fields.
1282 inode.
1349 * Fix e2fsck's resize inode handling in some additional corner cases.
1356 the old inode table blocks when we move the inode table.
1358 * Make sure that we don't write garbage when writing a large inode.
1368 the resize inode.
1410 * Add support for online resizing via the resize inode.
1429 * Fix an obscure, hard-to find bug in "e2fsck -S" caused by an inode
1432 user to manually set a specific inode field more conveniently, as
1660 * Fix handling of corrupted indirect blocks in the bad block inode.
1688 * When moving the journal or backing up the journal inode
1702 * Add support for storing the journal inode location in the superblock
1703 so that e2fsck can recover from a corrupted inode table after a power
1846 specified inode in the inode table.
1900 * E2fsck now updates the global free block and inode counters from
1903 locking the entire filesystem during block or inode allocation; if
2501 * Fixed mke2fs' display with inode numbers > 9999 (Fixes: Bug#25684).