Lines Matching refs:For
32 Support for ARB_fragment_program is assumed, but not required.
34 Support for ARB_fragment_program_shadow is assumed, but not required.
36 Support for EXT_framebuffer_object is assumed, but not required.
63 involve using a separate texture unit for each texture map or using 3D
71 of the N LOD in all three dimensions. For the TEXTURE_2D_ARRAY target,
73 same for all levels of detail. The texture then becomes an array of
132 (Note: COMPARE_REF_DEPTH_TO_TEXTURE_EXT is simply an alias for the
150 (Note: FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER is simply an alias for the
173 one of TEXTURE_3D for a three-dimensional texture or
174 TEXTURE_2D_ARRAY_EXT for an two-dimensional array texture.
175 Additionally, target may be either PROXY_TEXTURE_3D for a
176 three-dimensional proxy texture, or PROXY_TEXTURE_2D_ARRAY_EXT for a
200 of TEXTURE_2D for a two-dimensional texture, TEXTURE_1D_ARRAY_EXT for a
204 TEXTURE_CUBE_MAP_NEGATIVE_Z for a cube map texture. Additionally,
205 target may be either PROXY_TEXTURE_2D for a two-dimensional proxy
206 texture, PROXY_TEXTURE_1D_ARRAY_EXT for a one-dimensional proxy array
207 texture, or PROXY TEXTURE_CUBE_MAP for a cube map proxy texture in the
211 For the purposes of decoding the texture image, TexImage2D is
284 image array whose level is level_base. For a one-dimensional
286 w(x,y) = 0; for a two-dimensional texture or a two-dimensional array
293 "For a two-dimensional texture, two-dimensional array texture, or
298 "And for a one-dimensional texture or a one-dimensional array texture,"
302 "For one-dimensional array textures, h_b and d_b are treated as 1,
304 For two-dimensional array textures, d_b is always treated as one,
313 reduction of the level_base array. For one- and two-dimensional array
334 "For one-, two-, or three-dimensional textures and one- or
343 "In addition to image arrays for one-, two-, and three-dimensional
345 arrays for the cube map texture, partially instantiated image arrays
346 are maintained for one-, two-, and three-dimensional textures and one-
348 array is maintained for the cube map texture. Each proxy image array
350 values, as well as state for the red, green, blue, alpha, luminance,
363 Proxy arrays for one- and two-dimensional textures and one- and
379 The name space for texture objects is the unsigned integers, with zero
445 "Let D_t be the depth texture value, in the range [0, 1]. For
448 texture coordinate, clamped to the range [0, 1]. For texture lookups
525 how the 4-tuple is mapped into the coordinates used for sampling. The
533 are used by all texture targets. Component usage for each <texTarget>
552 Table X: Texture types accessed for each of the <texTarget>, and
554 input values used for each coordinate of the texture lookup, the
555 layer selector for array textures, and the reference value for
650 GetTexImage obtains... from the first image to the last for
655 For three-dimensional and two-dimensional array textures, pixel storage
686 S3TC texture compression is supported for two-dimensional array textures.
692 For array textures, images are not arranged in 4x4x4 or 4x4x2 blocks as in
699 S3TC compression is not supported for one-dimensional texture targets in
700 EXT_texture_compression_s3tc, and is not supported for one-dimensional
732 layers for texture
737 (1) Is "texture stack" a good name for this functionality?
745 convenient for applications.
749 before and should be left for a layered extension.
754 (3) How does LOD selection work for stacked textures?
756 RESOLVED. For 2D array textures the R coordinate is ignored, and
757 the LOD selection equations for 2D textures are used. For 1D
759 equations for 1D textures are used. The expected usage is in a
763 as for a 3D texture, or should a new query be added? How about for 1D
774 RESOLVED. For orthogonality, yes.
791 GL_NV_gpu_program4 also adds support for other features that are
793 for array textures.