Home | History | Annotate | Download | only in dcl.constexpr

Lines Matching refs:Literal

15 struct Literal {
16 constexpr Literal() {}
25 // shall be a literal type.
28 constexpr S(int, NonLiteral, N::C); // expected-error {{constexpr constructor's 2nd parameter type 'NonLiteral' is not a literal type}}
29 constexpr S(int, NonLiteral = 42); // expected-error {{constexpr constructor's 2nd parameter type 'NonLiteral' is not a literal type}}
33 constexpr S(Literal) = delete;
165 Literal l;
166 Literal m;
167 Literal n[3];
177 Literal l;