Home | History | Annotate | Download | only in dcl.constexpr

Lines Matching refs:Literal

16 struct Literal {
17 constexpr Literal() {}
46 constexpr ConstexprCtor(P...); // expected-note {{constructor template instantiation is not constexpr because 1st parameter type 'NonLiteral' is not a literal type}} \
47 expected-note {{constructor template instantiation is not constexpr because 2nd parameter type 'NonLiteral' is not a literal type}}
51 constexpr ConstexprCtor<NonLiteral> f3(); // expected-error {{not a literal type}}
52 constexpr ConstexprCtor<int, NonLiteral> f4(); // expected-error {{not a literal type}}
57 template<typename T> struct T1 : virtual Literal { // expected-note {{here}}
61 template<typename T> struct T2 : virtual T { // expected-note {{struct with virtual base class is not a literal type}} expected-note {{here}}
66 constexpr T2<Literal> g2(); // expected-error {{not a literal type}}
68 template<typename T> class T3 : public T { // expected-note {{class with virtual base class is not a literal type}}
72 constexpr T3<Literal> g3(); // ok
73 constexpr T3<VirtBase> g4(); // expected-error {{not a literal type}}