Lines Matching refs:throw
7 extern void (*r1)() throw(int);
8 extern void (*r1)() throw(int);
12 extern void (*r2)() throw(int);
13 extern void (*r2)() throw(INT);
16 extern void (*r3)() throw(int, float);
17 extern void (*r3)() throw(float, int);
19 // MS throw-any spec and no spec at all are compatible
21 extern void (*r4)() throw(...);
23 // throw(X) and no spec are not compatible
24 extern void (*r5)() throw(int); // expected-note {{previous declaration}}
28 extern void f5() throw(int); // expected-note {{previous declaration}}
32 extern void (*r7)() throw(int); // expected-note {{previous declaration}}
33 extern void (*r7)() throw(float); // expected-error {{exception specification in declaration does not match}}
36 extern void (*r8)() throw(int);
37 extern void (*r8)() throw(const int);
40 extern void (*r9)() throw(int, int);
41 extern void (*r9)() throw(int, int);
68 // noexcept(false) is compatible with MS throw(...)
70 extern void (*r16)() throw(...);
80 // noexcept(false) is compatible with dynamic specs that throw unless
82 //extern void (*r18)() throw(int);
85 // noexcept(true) is compatible with dynamic specs that don't throw
86 extern void (*r19)() throw();
90 extern void (*r20)() throw(); // expected-note {{previous declaration}}
93 extern void (*r21)() throw(int); // expected-note {{previous declaration}}
98 // with a throw(bad_alloc) spec, because C++0x makes an incompatible change
102 void* operator new(mysize_t) throw(std::bad_alloc);
105 void* operator new[](mysize_t) throw(std::bad_alloc);