Home | History | Annotate | Download | only in temp.explicit

Lines Matching refs:X2

56 struct X2 {
71 T X2<T, U>::static_member1 = 17; // expected-error{{cannot initialize}}
74 U X2<T, U>::static_member2; // expected-error{{no matching}}
76 template void X2<int, float>::f(int &, float);
77 template void X2<int, float>::f(int &, double); // expected-error{{does not refer}}
78 template void X2<int, int*>::f(int&, int*); // expected-note{{instantiation}}
80 template struct X2<int, float>::Inner;
81 template struct X2<int, Incomplete>::Inner; // expected-note{{instantiation}}
83 template int X2<int, float>::static_member1;
84 template int* X2<int*, float>::static_member1; // expected-note{{instantiation}}
86 NonDefaultConstructible X2<NonDefaultConstructible, int>::static_member1;
89 NonDefaultConstructible X2<int, NonDefaultConstructible>::static_member2; // expected-note{{instantiation}}