Home | History | Annotate | Download | only in dcl.constexpr

Lines Matching defs:Literal

15 struct Literal {
16 constexpr Literal() {}
33 struct T : SS { // expected-note {{base class 'SS' of non-literal type}}
34 constexpr T(); // expected-error {{non-literal type 'T' cannot have constexpr members}}
41 // - its return type shall be a literal type;
42 constexpr NonLiteral NonLiteralReturn(); // expected-error {{constexpr function's return type 'NonLiteral' is not a literal type}}
45 constexpr F NonLiteralReturn2; // expected-error {{constexpr function's return type 'NonLiteral' is not a literal type}}
47 // - each of its parameter types shall be a literal type;
48 constexpr int NonLiteralParam(NonLiteral); // expected-error {{constexpr function's 1st parameter type 'NonLiteral' is not a literal type}}
50 constexpr G NonLiteralParam2; // expected-error {{constexpr function's 1st parameter type 'NonLiteral' is not a literal type}}
57 // don't have a literal return type. Defaulted assignment operators can't be