Home | History | Annotate | Download | only in dcl.constexpr

Lines Matching refs:Literal

15 struct Literal {
16 constexpr Literal() {}
29 struct T : SS, NonLiteral { // expected-note {{base class 'NonLiteral' of non-literal type}}
31 constexpr int f(); // expected-error {{non-literal type 'T' cannot have constexpr members}}
38 // - its return type shall be a literal type;
39 constexpr NonLiteral NonLiteralReturn() { return {}; } // expected-error {{constexpr function's return type 'NonLiteral' is not a literal type}}
40 constexpr void VoidReturn() { return; } // expected-error {{constexpr function's return type 'void' is not a literal type}}
45 // - each of its parameter types shall be a literal type;
46 constexpr int NonLiteralParam(NonLiteral) { return 0; } // expected-error {{constexpr function's 1st parameter type 'NonLiteral' is not a literal type}}
55 // don't have a literal return type. Defaulted assignment operators can't be