Home | History | Annotate | Download | only in except.spec

Lines Matching defs:noexcept

25 // Simple parser tests, noexcept specification.
29 void f1() noexcept { }
30 void f2() noexcept (true) { }
31 void f3() noexcept (false) { }
32 void f4() noexcept (1 < 2) { }
35 void foo() noexcept { }
36 void bar() noexcept (true) { }
39 void (*fptr1)() noexcept;
40 void (*fptr2)() noexcept (true);
46 void f() throw(int) noexcept { } // expected-error {{cannot have both}}
47 void g() noexcept throw(int) { } // expected-error {{cannot have both}}
51 // Sema tests, noexcept specification
57 void g1() noexcept(A()); // expected-error {{not contextually convertible}}
58 void g2(bool b) noexcept(b); // expected-error {{argument to noexcept specifier must be a constant expression}}
68 void g(T x) noexcept((sizeof(T) == sizeof(int)) || noexcept(f(x))) { }
77 static int f() noexcept(1/X) { return 10; } // expected-error{{argument to noexcept specifier must be a constant expression}} expected-note{{division by zero}}