Home | History | Annotate | Download | only in except.spec

Lines Matching full:void

11   void f() throw() { }
13 void g(int) throw(X) { }
15 void h() throw(X, Y) { }
18 void foo() throw (X, Y) { }
21 void (*fptr)() throw();
29 void f1() noexcept { }
30 void f2() noexcept (true) { }
31 void f3() noexcept (false) { }
32 void f4() noexcept (1 < 2) { }
35 void foo() noexcept { }
36 void bar() noexcept (true) { }
39 void (*fptr1)() noexcept;
40 void (*fptr2)() noexcept (true);
46 void f() throw(int) noexcept { } // expected-error {{cannot have both}}
47 void g() noexcept throw(int) { } // expected-error {{cannot have both}}
57 void g1() noexcept(A()); // expected-error {{not contextually convertible}}
58 void g2(bool b) noexcept(b); // expected-error {{argument to noexcept specifier must be a constant expression}}
68 void g(T x) noexcept((sizeof(T) == sizeof(int)) || noexcept(f(x))) { }
70 void h() {
80 void g() { A<0>::f(); } // expected-note{{in instantiation of exception specification for 'f' requested here}}