Home | History | Annotate | Download | only in except.spec

Lines Matching full:void

10   void f() throw(int);
13 void (*fp)() throw (int);
16 void g(void pfa() throw(int));
24 void (*h())() throw(int);
29 void (*i() throw(int))(void (*)() throw(float)) throw(double);
32 void (**k)(void pfa() throw(int)); // no-error
35 void (**j)() throw(int); // expected-error {{not allowed beyond a single}}
38 void (**(*h())())() throw(int); // expected-error {{not allowed beyond a single}}
46 void f() noexcept(false);
48 void (*fp)() noexcept(false);
50 void g(void pfa() noexcept(false));
54 void (*h())() noexcept(false);
56 void (*i() noexcept(false))(void (*)() noexcept(true)) noexcept(false);
58 void (**k)(void pfa() noexcept(false)); // no-error
60 void (**j)() noexcept(false); // expected-error {{not allowed beyond a single}}
62 void (**(*h())())() noexcept(false); // expected-error {{not allowed beyond a single}}