Home | History | Annotate | Download | only in except.spec

Lines Matching full:void

26 void s1() throw();
27 void s2() throw(int);
28 void s3() throw(A);
29 void s4() throw(B1);
30 void s5() throw(D);
31 void s6();
32 void s7() throw(int, float);
33 void (*s8())() throw(B1); // s8 returns a pointer to function with spec
34 void s9(void (*)() throw(B1)); // s9 takes pointer to function with spec
36 void s10() noexcept;
37 void s11() noexcept(true);
38 void s12() noexcept(false);
40 void fnptrs()
43 void (*t1)() throw() = &s1; // valid
46 void (&t2)() throw() = s2; // expected-error {{not superset}}
47 void (*t3)() throw(int) = &s2; // valid
48 void (*t4)() throw(A) = &s1; // valid
52 void (*t5)() = &s1; // valid
58 void (*t6)() throw(B1);
65 void (*(*t7)())() throw(B1) = &s8; // valid
66 void (*(*t8)())() throw(A) = &s8; // expected-error {{return types differ}}
67 void (*(*t9)())() throw(D) = &s8; // expected-error {{return types differ}}
68 void (*t10)(void (*)() throw(B1)) = &s9; // valid expected-warning{{disambiguated}}
69 void (*t11)(void (*)() throw(A)) = &s9; // expected-error {{argument types differ}} expected-warning{{disambiguated}}
70 void (*t12)(void (*)() throw(D)) = &s9; // expected-error {{argument types differ}} expected-warning{{disambiguated}}
75 struct Str1 { void f() throw(int); }; // expected-note {{previous declaration}}
76 void Str1::f() // expected-warning {{missing exception specification}}
80 void mfnptr()
82 void (Str1::*pfn1)() throw(int) = &Str1::f; // valid
83 void (Str1::*pfn2)() = &Str1::f; // valid
84 void (Str1::*pfn3)() throw() = &Str1::f; // expected-error {{not superset}}