Home | History | Annotate | Download | only in except.spec

Lines Matching defs:noexcept

35   virtual void f7() noexcept;
36 virtual void f8() noexcept;
37 virtual void f9() noexcept(false);
38 virtual void f10() noexcept(false);
41 virtual void f12() noexcept;
42 virtual void f13() noexcept(false);
54 virtual void g6() noexcept; // expected-note {{overridden virtual function is here}}
55 virtual void g7() noexcept; // expected-note {{overridden virtual function is here}}
57 virtual void g8() noexcept; // expected-note {{overridden virtual function is here}}
71 virtual void f7() noexcept;
72 virtual void f8() noexcept(true);
73 virtual void f9() noexcept(true);
74 virtual void f10() noexcept(false);
76 virtual void f11() noexcept;
79 virtual void f14() noexcept(true);
81 virtual void f15() noexcept;
90 virtual void g6() noexcept(false); // expected-error {{exception specification of overriding function is more lax}}
94 virtual void g9() noexcept(false); // expected-error {{exception specification of overriding function is more lax}}
95 virtual void g10() noexcept(false); // expected-error {{exception specification of overriding function is more lax}}