Lines Matching full:void
19 template<typename T> void f0(T) {
23 template<> void f0(NonDefaultConstructible) { }
25 void test_f0(NonDefaultConstructible NDC) {
29 template<> void f0(int);
30 template<> void f0(long);
33 template<> void N0::f0(int) { } // okay
36 template<> void N0::f0(long) { } // expected-error{{does not enclose namespace}}
39 template<> void N0::f0(double) { }
42 template<typename T> void f(T);
44 template<> void f(int); // expected-error{{in class scope}}
54 void f1(T t) {
65 void ft1(T t, U u);
72 void N0::X0<T>::ft1(T t, U u) {
78 template<> struct N0::X0<void> { };
79 N0::X0<void> test_X0;
82 template<> struct N0::X0<const void> { }; // expected-error{{class template specialization of 'X0' must originally be declared in namespace 'N0'}}
86 template<> struct X0<volatile void>;
89 template<> struct N0::X0<volatile void> {
90 void f1(void *);
94 template<> void N0::X0<void*>::f1(void *) { }
96 void test_spec(N0::X0<void*> xvp, void *vp) {
101 template<> void X0<volatile void>::f1(void *) { } // expected-error{{no function template matches}}
103 template<> void X0<const volatile void*>::f1(const volatile void*);
106 void test_x0_cvvoid(N0::X0<const volatile void*> x0, const volatile void *cvp) {
139 struct X0<void*>::Inner { };
168 N0::X0<void*>::Inner inner0;
178 struct X0<void*>::InnerTemplate<int> { };
201 N0::X0<void*>::InnerTemplate<int> inner_template0;
210 void X0<void*>::ft1(void*, const void*) { }
213 void X0<void*>::ft1(void *, int);
216 void X0<void*>::ft1(void *, unsigned);
219 void X0<void*>::ft1(void *, long);
223 void N0::X0<void*>::ft1(void *, unsigned) { } // okay
226 void N0::X0<void*>::ft1(void *, float) { }
230 void N0::X0<void*>::ft1(void *, long) { } // expected-error{{does not enclose namespace}}
234 void test_func_template(N0::X0<void *> xvp, void *vp, const void *cvp,
243 template<class T> void f(T&);
249 void mem_func();
255 void mem_func_template(U&);
268 template<> void f(X1&);
269 template<> void f<X2>(X2&);
275 template<> void X0<X2>::mem_func();
279 template<> template<typename T> void X0<X2>::mem_func_template(T&) { }
287 template<> void has_inline_namespaces::f(X3&);
288 template<> void has_inline_namespaces::f<X4>(X4&);
294 template<> void has_inline_namespaces::X0<X4>::mem_func();
300 void has_inline_namespaces::X0<X4>::mem_func_template(T&) { }