Home | History | Annotate | Download | only in docs

Lines Matching refs:the

27     GLX_SGI_swap_control affects the definition of this extension.
28 GLX_MESA_swap_control affects the definition of this extension.
29 GLX_OML_sync_control affects the definition of this extension.
35 This extension allows an application to determine what portion of the
36 swap period has elapsed since the last swap operation completed. The
37 "usage" value is a floating point value on the range [0,max] which is
44 where td is the time measured from the last completed buffer swap (or
45 call to enable the statistic) to when the next buffer swap completes, tf
46 is the entire time for a frame which may be multiple screen refreshes
47 depending on the swap interval as set by the GLX_SGI_swap_control or
50 The value, percent, indicates the amount of time spent between the
51 completion of the two swaps. If the value is in the range [0,1], the
52 buffer swap occurred within the time period required to maintain a
53 constant frame rate. If the value is in the range (1,max], a constant
54 frame rate was not achieved. The value indicates the number of frames
58 WGL_I3D_swap_frame_usage. In WGL_I3D_swap_frame_usage, the measurement
59 is taken from the completion of one swap to the issuance of the next.
61 completions, as a significant amount of time may pass between the
62 issuance of a swap and the swap actually occurring.
89 Additions to Chapter 2 of the 1.4 GL Specification (OpenGL Operation)
93 Additions to Chapter 3 of the 1.4 GL Specification (Rasterization)
97 Additions to Chapter 4 of the 1.4 GL Specification (Per-Fragment Operations
98 and the Framebuffer)
102 Additions to Chapter 5 of the 1.4 GL Specification (Special Functions)
106 Additions to Chapter 6 of the 1.4 GL Specification (State and State Requests)
110 Additions to the GLX 1.3 Specification
112 The frame usage is measured as the percentage of the swap period elapsed
113 between two buffer-swap operations being committed. In unextended GLX the
114 swap period is the vertical refresh time. If SGI_swap_control or
115 MESA_swap_control are supported, the swap period is the vertical refresh
116 time multiplied by the swap interval (or one if the swap interval is set
119 If OML_sync_control is supported, the swap period is the vertical
120 refresh time multiplied by the divisor parameter to
121 glXSwapBuffersMscOML. The frame usage in this case is less than 1.0 if
122 the swap is committed before target_msc, and is greater than or equal to
123 1.0 otherwise. The actual usage value is based on the divisor and is
131 that represents the current swap usage, as defined above.
133 Missed frame swaps can be tracked by calling the following function:
139 synchronizes with the next frame vertical sync before it returns.
140 If a swap is missed based in the rate control specified by the
141 <interval> set by glXSwapIntervalSGI or the default swap of once
142 per frame, the missed frame count is incremented.
144 The current missed frame count and total number of swaps since
145 the last call to glXBeginFrameTrackingMESA can be obtained by
146 calling the following function:
154 The location pointed to by <swapCount> will be updated with the
155 number of swaps that have been committed. This value may not match the
157 queued by the implementation. This function can be called at any
160 The location pointed to by <missedFrames> will contain the number
161 swaps that missed the specified frame. The frame usage for the
162 last missed frame is returned in the location pointed to by
165 Frame tracking is disabled by calling the function
170 This function will not return until all swaps have occurred. The
174 If these functions are successful, zero is returned. If the context
180 If the function succeeds, zero is returned. If the function
181 fails, one of the following error codes is returned:
183 GLX_BAD_CONTEXT The current rendering context is not a direct