Home | History | Annotate | Download | only in temp.expl.spec

Lines Matching full:void

3 template<class T> void f(T) { /* ... */ }
4 template<class T> inline void g(T) { /* ... */ }
6 // CHECK: define void @_Z1gIiEvT_
7 template<> void g<>(int) { /* ... */ }
11 void f() { }
12 void g();
13 void h();
17 void X<T>::g() {
21 inline void X<T>::h() {
24 // CHECK: define void @_ZN1XIiE1fEv
25 template<> void X<int>::f() { }
27 // CHECK: define void @_ZN1XIiE1hEv
28 template<> void X<int>::h() { }
30 // CHECK: define linkonce_odr void @_Z1fIiEvT_
31 template<> inline void f<>(int) { /* ... */ }
33 // CHECK: define linkonce_odr void @_ZN1XIiE1gEv
34 template<> inline void X<int>::g() { }
36 void test(X<int> xi) {