Home | History | Annotate | Download | only in temp.expl.spec

Lines Matching refs:IntHolder

3 struct IntHolder {
4 IntHolder(int);
25 // Explicitly specialize the members of X<IntHolder, long> to not cause
28 void X<IntHolder, long>::f();
31 struct X<IntHolder, long>::Inner; // expected-note{{forward declaration}}
34 IntHolder X<IntHolder, long>::value;
36 IntHolder &test_X_IntHolderInt(X<IntHolder, long> xih) {
40 X<IntHolder, long>::Inner inner; // expected-error {{incomplete}}
42 return X<IntHolder, long>::value; // okay, uses specialization