Lines Matching full:note
12 template struct X0<void>; // expected-note{{instantiation}}
23 template void f0(int C::*); // expected-note{{instantiation}}
42 template struct X1<int>::Inner<void>; // expected-note{{instantiation}}
47 template void X1<int>::f<>(int&, int*); // expected-note{{instantiation}}
50 struct Incomplete; // expected-note{{forward declaration}}
51 struct NonDefaultConstructible { // expected-note{{candidate constructor (the implicit copy constructor) not viable}}
52 NonDefaultConstructible(int); // expected-note{{candidate constructor}}
78 template void X2<int, int*>::f(int&, int*); // expected-note{{instantiation}}
81 template struct X2<int, Incomplete>::Inner; // expected-note{{instantiation}}
84 template int* X2<int*, float>::static_member1; // expected-note{{instantiation}}
89 NonDefaultConstructible X2<int, NonDefaultConstructible>::static_member2; // expected-note{{instantiation}}