Home | History | Annotate | Download | only in except.spec

Lines Matching full:operator

15 // Copy-assignment operator.
17 CA0 &operator=(const CA0&) throw(A);
20 CA1 &operator=(const CA1&) throw(B);
25 CA2 &(CA2::*captr1)(const CA2&) throw(A, B) = &CA2::operator=;
26 CA2 &(CA2::*captr2)(const CA2&) throw(A, B, C) = &CA2::operator=;
27 CA2 &(CA2::*captr3)(const CA2&) throw(A) = &CA2::operator=; // expected-error{{target exception specification is not superset of source}}
28 CA2 &(CA2::*captr4)(const CA2&) throw(B) = &CA2::operator=; // expected-error{{target exception specification is not superset of source}}
47 NoThrowMove &operator=(const NoThrowMove &);
48 NoThrowMove &operator=(NoThrowMove &&) noexcept;
52 NoThrowMoveOnly &operator=(NoThrowMoveOnly &&) noexcept;