Home | History | Annotate | Download | only in strace

Lines Matching refs:Fix

110 - build fix for newer kernel headers (#457291)
111 - fix CLONE_VFORK handling (#455078)
117 - fix biarch stat64 decoding (#222275)
118 - fix spurious "..." in printing of environment strings (#358241)
120 - fix hang wait on exited child with exited child (#354261)
121 - fix biarch fork/vfork (-f) tracing (#447475)
122 - fix biarch printing of negative argument kill (#430585)
123 - fix biarch decoding of error return values (#447587)
124 - fix -f tracing of CLONE_VFORK (#455078)
125 - fix ia64 register clobberation in -f tracing (#453438)
127 - fix futex argument decoding (#448628, #448629)
130 - fix multithread issues (#240962, #240961, #247907)
131 - fix spurious SIGSTOP on early interrupt (#240986)
132 - fix utime for biarch (#247185)
133 - fix -u error message (#247170)
135 - fix argv/envp printing with small -s settings, and for biarch
141 - fix -ff -o behavior (#204950, #218435, #193808, #219423)
146 - fix race in child setup under -f (#180293)
156 - Fix ia64 syscall decoding (#206768)
157 - Fix build with glibc-2.4.90-33 and up on all arches but ia64
158 - Fix build against 2.6.18+ headers
161 - Fix bogus decoding of syscalls >= 300 (#201462, #202620).
173 - Fix biarch decoding of socket syscalls (#174354).
174 - Fix biarch -e support (#173986).
176 - Fix ipc syscall decoding (#164755).
183 - Fix setsockopt decoding on 64-bit (#162449).
184 - Fix typos in socket option name strings (#161578).
188 - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
189 - Fix errors detaching from multithreaded process on interrupt (#161919).
190 - Note 4.5.12 fix for crash handling bad signal numbers (#162739).
193 - Fix known syscall recognition for IA32 processes on x86-64 (#158934).
194 - Fix bad output for ptrace on x86-64 (#159787).
195 - Fix potential buffer overruns (#151570, #159196).
204 - Note 4.5.10 select fix (#151570).
207 - Fix select handling on nonstandard fd_set sizes.
209 - Fix initial execve output with -i (#143365).
213 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
214 - fix -e signal=NAME parsing (#143362)
215 - fix x86_64 exit_group syscall handling
220 - fix potential crash in getxattr printing
223 - fix multithreaded exit handling (#132150, #135254)
224 - fix ioctl name matching (#129808)
229 - fix clock_* and timer_* argument output (#131420)
265 - revert bogus s390 fix
330 - fix strace -f (Roland McGrath, #68994)
341 - fix for the last patch by Jeff Law (#62591)
399 - fix sigreturn on sparc
402 - fix stat64 misdef (#10485)
415 - fix socketcall on sparc.
418 - fix KERN_SECURELVL compile problem
421 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
457 - fix typo (printf, not tprintf).
460 - fix compile problem on sparc.