Home | History | Annotate | Download | only in dcl.constexpr

Lines Matching full:constexpr

6   constexpr int f();
7 constexpr int g() const;
8 constexpr int h();
10 static constexpr int Sf();
11 /*static*/ constexpr void *operator new(size_t) noexcept;
12 template<typename T> constexpr T tm();
13 template<typename T> static constexpr T ts();
28 constexpr int S::f() const { return 0; }
29 constexpr int S::g() { return 1; }
30 constexpr int S::h() { return 0; }
32 constexpr int S::Sf() { return 2; }
33 constexpr void *S::operator new(size_t) noexcept { return 0; }
34 template<typename T> constexpr T S::tm() { return T(); }
35 template<typename T> constexpr T S::ts() { return T(); }
39 class debug_flag { // expected-note {{not an aggregate and has no constexpr constructors}}
42 constexpr bool is_on(); // expected-error {{non-literal type 'std_example::debug_flag' cannot have constexpr members}}
47 constexpr int bar(int x, int y) // expected-note {{here}}
49 int bar(int x, int y) // expected-error {{non-constexpr declaration of 'bar' follows constexpr declaration}}
54 // The constexpr specifier is allowed for static member functions of non-literal types.
57 static constexpr bool isDebugFlag();