Home | History | Annotate | Download | only in except.spec

Lines Matching refs:noexcept

44 // noexcept is compatible with itself
45 extern void (*r10)() noexcept;
46 extern void (*r10)() noexcept;
48 // noexcept(true) is compatible with noexcept
49 extern void (*r11)() noexcept;
50 extern void (*r11)() noexcept(true);
52 // noexcept(false) isn't
53 extern void (*r12)() noexcept; // expected-note {{previous declaration}}
54 extern void (*r12)() noexcept(false); // expected-error {{does not match}}
57 extern void (*r13)() noexcept(1 < 2);
58 extern void (*r13)() noexcept(2 > 1);
60 // noexcept(false) is incompatible with noexcept(true)
61 extern void (*r14)() noexcept(true); // expected-note {{previous declaration}}
62 extern void (*r14)() noexcept(false); // expected-error {{does not match}}
64 // noexcept(false) is compatible with itself
65 extern void (*r15)() noexcept(false);
66 extern void (*r15)() noexcept(false);
68 // noexcept(false) is compatible with MS throw(...)
69 extern void (*r16)() noexcept(false);
72 // noexcept(false) is *not* compatible with no spec
74 extern void (*r17)() noexcept(false); // expected-error {{does not match}}
78 void f17() noexcept(false);
80 // noexcept(false) is compatible with dynamic specs that throw unless
83 //extern void (*r18)() noexcept(false);
85 // noexcept(true) is compatible with dynamic specs that don't throw
87 extern void (*r19)() noexcept(true);
91 extern void (*r20)() noexcept(false); // expected-error {{does not match}}
94 extern void (*r21)() noexcept(true); // expected-error {{does not match}}