Home | History | Annotate | Download | only in temp.explicit

Lines Matching full:template

3 template<typename T>
12 template class X0<int(int)>; // ok; nothing gets instantiated.
14 template<typename T>
19 template<typename T>
24 template<typename T>
27 template class X0<int>; // ok
30 template<typename T>
36 template struct X1<int>; // expected-note {{here}}
38 extern template struct X1<char>; // ok
40 template struct X1<char>; // expected-note {{here}}