Home | History | Annotate | Download | only in except.spec

Lines Matching refs:throw

9 void ic1() throw(void); // expected-error {{incomplete type 'void' is not allowed in exception specification}}
10 void ic2() throw(Incomplete); // expected-error {{incomplete type 'Incomplete' is not allowed in exception specification}}
11 void ic3() throw(void*);
12 void ic4() throw(Incomplete*); // expected-error {{pointer to incomplete type 'Incomplete' is not allowed in exception specification}}
13 void ic5() throw(Incomplete&); // expected-error {{reference to incomplete type 'Incomplete' is not allowed in exception specification}}
18 void tf() throw(TEx<int>); // expected-error {{implicit instantiation of undefined template}}
22 void f() throw(DR437);
23 void g() throw(DR437*);
24 void h() throw(DR437&);
30 void f() throw(DR437_out);
31 void g() throw(DR437_out*);
32 void h() throw(DR437_out&);