Lines Matching refs:wl_buffer
39 wl_buffer objects. On the server side, this extension also
41 from a wl_buffer
60 struct wl_buffer *buffer,
98 A wl_buffer can have several planes, typically in case of planar
102 used to first query the wl_buffer texture format using
103 EGL_TEXTURE_FORMAT as the attribute. If the wl_buffer object is
104 not an EGL wl_buffer (wl_shm and other wayland extensions can
105 create wl_buffer objects of different types), this query will
106 return EGL_FALSE. In that case the wl_buffer can not be used with
146 After querying the wl_buffer layout, create EGLImages for the
147 planes by calling eglCreateImageKHR with wl_buffer as
154 from a wl_buffer in any way (such as glTexImage2D, binding the
158 EGL_HEIGHT to query the width and height of the wl_buffer.