Home | History | Annotate | Download | only in dcl.constexpr

Lines Matching refs:Literal

16 struct Literal {
17 constexpr Literal() {}
30 struct T : SS, NonLiteral { // expected-note {{base class 'NonLiteral' of non-literal type}}
32 constexpr int f() const; // expected-error {{non-literal type 'T' cannot have constexpr members}}
39 // - its return type shall be a literal type;
40 constexpr NonLiteral NonLiteralReturn() const { return {}; } // expected-error {{constexpr function's return type 'NonLiteral' is not a literal type}}
43 // expected-error@-2 {{constexpr function's return type 'void' is not a literal type}}
49 // - each of its parameter types shall be a literal type;
50 constexpr int NonLiteralParam(NonLiteral) const { return 0; } // expected-error {{constexpr function's 1st parameter type 'NonLiteral' is not a literal type}}
60 // don't have a literal return type. Defaulted assignment operators can't be
134 // - a definition of a variable of non-literal type
135 NonLiteral nl; // expected-error {{variable of non-literal type 'NonLiteral' cannot be defined in a constexpr function}}
176 Literal a;