Lines Matching refs:dropbear
6 if test ! -e /etc/dropbear/dropbear_rsa_host_key; then
8 echo "Converting existing OpenSSH RSA host key to Dropbear format."
9 /usr/lib/dropbear/dropbearconvert openssh dropbear \
10 /etc/ssh/ssh_host_rsa_key /etc/dropbear/dropbear_rsa_host_key
12 echo "Generating Dropbear RSA key. Please wait."
13 dropbearkey -t rsa -f /etc/dropbear/dropbear_rsa_host_key
16 if test ! -e /etc/dropbear/dropbear_dss_host_key; then
18 echo "Converting existing OpenSSH RSA host key to Dropbear format."
19 /usr/lib/dropbear/dropbearconvert openssh dropbear \
20 /etc/ssh/ssh_host_dsa_key /etc/dropbear/dropbear_dss_host_key
22 echo "Generating Dropbear DSS key. Please wait."
23 dropbearkey -t dss -f /etc/dropbear/dropbear_dss_host_key
26 if test ! -s /etc/default/dropbear; then
30 OpenSSH appears to be installed. Setting /etc/default/dropbear so that
31 Dropbear will not start by default. Edit this file to change this behaviour.
34 cat >>/etc/default/dropbear <<EOT
36 # change to NO_START=0 to enable Dropbear
41 cat >>/etc/default/dropbear <<EOT
42 # the TCP port that Dropbear listens on
45 # any additional arguments for Dropbear
52 # RSA hostkey file (default: /etc/dropbear/dropbear_rsa_host_key)
53 #DROPBEAR_RSAKEY="/etc/dropbear/dropbear_rsa_host_key"
55 # DSS hostkey file (default: /etc/dropbear/dropbear_dss_host_key)
56 #DROPBEAR_DSSKEY="/etc/dropbear/dropbear_dss_host_key"
60 if test -x /etc/init.d/dropbear; then
61 update-rc.d dropbear defaults >/dev/null
63 invoke-rc.d dropbear restart
65 /etc/init.d/dropbear restart