Lines Matching full:program
38 The concept is that vertex and fragment program debuggers will be
45 2. Query the current program string's execution position.
46 3. Query the current values of intermediate program values.
50 be called prior to executing each vertex or fragment program instruction.
54 current program values to be queried (such as temporaries, input
57 There are flags for enabling/disabling the program callbacks.
60 program string) can be queried with
108 6. Debuggers often allow one to modify intermediate program values,
177 vertex program, respectively. The callbacks are enabled and
187 program is currently executing and <data> will be the value
211 Add a new section 6.1.3 "Program Value Queries":
219 Is used to query the value of program variables and registers
220 during program execution. GetProgramRegisterfvMESA may only be
225 attribute, temporary, or result register in the program string.
227 values in <v>. If <name> doesn't exist in the program string,
256 a supported vertex or fragment program type.
260 Begin and End when a vertex or fragment program is currently executing.
263 GetProgramRegisterfvMESA if <target> is not a program target supported
268 does not name a known program register or variable.
271 register query is attempted for a program target that's not currently
316 /* This is called by the GL when the vertex program is executing.
348 /* define/bind a vertex program */