Home | History | Annotate | Download | only in dcl.constexpr

Lines Matching refs:NonLiteral

12 struct NonLiteral { // expected-note 3{{no constexpr constructors}}
13 NonLiteral() {}
14 NonLiteral(int) {}
30 struct T : SS, NonLiteral { // expected-note {{base class 'NonLiteral' of non-literal type}}
40 constexpr NonLiteral NonLiteralReturn() const { return {}; } // expected-error {{constexpr function's return type 'NonLiteral' is not a literal type}}
46 typedef NonLiteral F() const;
50 constexpr int NonLiteralParam(NonLiteral) const { return 0; } // expected-error {{constexpr function's 1st parameter type 'NonLiteral' is not a literal type}}
51 typedef int G(NonLiteral) const;
135 NonLiteral nl; // expected-error {{variable of non-literal type 'NonLiteral' cannot be defined in a constexpr function}}
182 NonLiteral nl;
183 constexpr NonLiteral &ExternNonLiteralVarDecl() {
184 extern NonLiteral nl;