Lines Matching full:default
38 // FIXME: the exception specification on the default constructor is wrong:
80 Derived() noexcept(false) = default;
81 Derived(const Derived&) noexcept(false) = default;
82 Derived(Derived&&) noexcept(false) = default;
83 Derived &operator=(const Derived&) noexcept(false) = default;
84 Derived &operator=(Derived&&) noexcept(false) = default;
85 ~Derived() noexcept(false) = default;
88 Derived2() = default;
89 Derived2(const Derived2&) = default;
90 Derived2(Derived2&&) = default;
91 Derived2 &operator=(const Derived2&) = default;
92 Derived2 &operator=(Derived2&&) = default;
93 ~Derived2() = default;
96 Derived3() noexcept(true) = default; // expected-error {{does not match the calculated}}
97 Derived3(const Derived3&) noexcept(true) = default; // expected-error {{does not match the calculated}}
98 Derived3(Derived3&&) noexcept(true) = default; // expected-error {{does not match the calculated}}
99 Derived3 &operator=(const Derived3&) noexcept(true) = default; // expected-error {{does not match the calculated}}
100 Derived3 &operator=(Derived3&&) noexcept(true) = default; // expected-error {{does not match the calculated}}
101 ~Derived3() noexcept(true) = default; // expected-error {{does not match the calculated}}