Lines Matching full:instantiation
4 // explicit instantiation of the function template.
10 // template shall be in scope at the point of the explicit instantiation of
16 template void X1<int>::f0<int>(int); // expected-error {{implicit instantiation of undefined template}}
19 // at the point of the explicit instantiation of the class template or class
21 template struct X1<float>; // expected-error{{explicit instantiation of undefined template}}
31 template struct X2<int>::Inner<float>; // expected-error{{explicit instantiation of undefined template}}
34 // explicit instantiation of a member function or a static data member of the
42 // point of an explicit instantiation of the member class.
45 // If the declaration of the explicit instantiation names an implicitly-declared
47 template X2<int>::X2(); // expected-error{{not an instantiation}}
48 template X2<int>::X2(const X2&); // expected-error{{not an instantiation}}
49 template X2<int>::~X2(); // expected-error{{not an instantiation}}
50 template X2<int> &X2<int>::operator=(const X2<int>&); // expected-error{{not an instantiation}}
79 extern template class BasicStringPiece<int>; // expected-error{{explicit instantiation of undefined template 'PR11599::BasicStringPiece<int>}}