Home | History | Annotate | Download | only in debian

Lines Matching full:debugfs

43   * Debugfs now uses a more concise format for listing extents in its
45 * Debugfs can now use direct I/O to access the file system with the -D option
50 * Debugfs will correctly show the progress bar even when UTF-8
119 * Debugfs's "logdump -b <blk>" now properly shows the allocation status
196 * Fix a file descriptor leak in debugfs when sourcing a command file
241 * Enhance debugfs's 'stat' command to print basic extent information
307 * Fix debugfs from core dumping if the logdump command fails to open the
329 * Add an "-a" option to debugfs's close_filesys command
388 * Debugfs can now set i_file_acl_high via the set_inodes_field command
389 * Debugfs will now display a 64-bit file acl block
398 * Fix a segfault in debugfs when running stat without an open filesystem
415 * Fix debugfs's ncheck output to suppress extra characters at the end
444 * Fix a regression in debugfs's logdump command so it works for
489 * Fix debugfs's ncheck command so it prints all of the names of
506 * debugfs: Fix ncheck to print all pathnames for all of the specified inodes
509 * debugfs: Add the ability to specify the hash seed and to specify the
560 * Add supported_features command to debugfs
594 * Fix "dumpe2fs -i" and "debugfs -i". (Closes: #495830)
606 * Teach debugfs's htree command to work with extent-based directories.
706 * The debugfs "ls" command now supports the -p option, which causes
726 * Clarify debugfs man page. (Closes: #486463)
746 * debugfs: Don't bother using a pager of stdout is not a tty
747 * Fix tune2fs and debugfs to correctly parse time strings during
810 * Add support for new superblock fields to debugfs's set_super_value command
811 * Teach debugfs to print "mostly-printable" xattr strings, such as is
873 * Fix debugfs's lsdel command so it works on large files
1028 * Fix signed vs. unsigned problem in debugfs' setb/testb/freeb commands
1029 * Enhance debugfs's date parser so it acccepts integer values
1033 * Enhance debugfs so it can modify the block group descriptors using
1045 * Fix mke2fs and debugfs to support large (> 16 bit) uid's and gid's
1062 * Fix dump_unused segfault in debugfs when a filesystem is not open
1066 * Let the debugfs lcd command work even if a filesystem is not open
1075 * Allow debugfs to dump > 2GB files. (Closes: #412614)
1132 * Fix debugfs to print unsigned values for EA's
1138 * Fix debugfs coredump when lsdel is run without an open filesystem
1167 * Fix debugfs's dump_unused command so it will not core dump on
1187 * Fix the debugfs commands htree_dump, dx_hash, and list_dir so they
1239 * Fix debugfs's icheck to correctly report the owner of an EA block
1298 * Add new debugfs command, set_current_time which sets the time used to
1309 * Fix debugfs's set_inode_field so that successfully sets the i_size field
1323 * Fix debugfs's set_inode_fields command so it doesn't silently fail
1391 * Fix debugfs seg fault when the stat command is given and a filesystem
1433 * Add support in e2fsck and debugfs for extended attributes in inodes.
1485 * Add set_super_value jnl_blocks[] in debugfs.
1544 * Debugfs now supports a new command, set_inode_field, which allows a
1547 * Debugfs's set_super_value command has been enhanced so that the user
1554 * Fix bug in debugfs where kill_file would lead to errors when deleting
1601 * Add debugfs -d option to use a separate source of data blocks when
1662 * Make the debugfs command's link command set the filetype information
1706 * Update debugfs to support new large major/minor device numbers
1711 * Fix the debugfs man page. (Closes: #232406)
1713 * e2fsck and debugfs now correctly deals with symlinks that have
1729 for debugfs (unfortunately, Debian policy says we must use
1749 * Debugfs now searches for the appropriate pager to use, beginning
1753 * Fix bug where using debugfs to copy a file from /dev/null caused
1758 * Debugfs's mkdir command will automatically expand the directory if
1924 * Fix debugfs core-dumping problem caused by getopt. (Works around: #192834)
1958 * Add new debugfs command, imap, which prints the location of a
2068 * Remove --disable-debugfs from mips-nopic flags (Closes: #162674).
2386 ** Fix debugfs dump cmd looping on disk errors (Closes: #79163)
2394 * Moved debugfs back from /usr/sbin/ to /sbin/ (Closes: #97035).
2464 * Fix Y2K display-only bug in debugfs - "ls -l" displayed raw tm_year,
2744 * Included example command tables from debugfs in ss-dev.