Home | History | Annotate | Download | only in except.spec

Lines Matching full:overriding

84   virtual void g1() throw(int); // expected-error {{exception specification of overriding function is more lax}}
85 virtual void g2(); // expected-error {{exception specification of overriding function is more lax}}
86 virtual void g3() throw(D); // expected-error {{exception specification of overriding function is more lax}}
87 virtual void g4() throw(A); // expected-error {{exception specification of overriding function is more lax}}
88 virtual void g5() throw(P); // expected-error {{exception specification of overriding function is more lax}}
90 virtual void g6() noexcept(false); // expected-error {{exception specification of overriding function is more lax}}
91 virtual void g7(); // expected-error {{exception specification of overriding function is more lax}}
93 virtual void g8() throw(int); // expected-error {{exception specification of overriding function is more lax}}
94 virtual void g9() noexcept(false); // expected-error {{exception specification of overriding function is more lax}}
95 virtual void g10() noexcept(false); // expected-error {{exception specification of overriding function is more lax}}