Home | History | Annotate | Download | only in temp.deduct.call

Lines Matching refs:invoke

52   template<class T> void invoke(void (*f)(T)) { f(T()); } // expected-note 6 {{couldn't infer template argument}} \
58 invoke(&temp); // expected-error {{no matching function for call to 'invoke'}}
59 invoke(&temp<>); // expected-error {{no matching function for call to 'invoke'}}
62 invoke(&temp<int>);
70 invoke(&over);
77 invoke(&over); // expected-error {{no matching function for call to 'invoke'}}
85 invoke(&temp2); // expected-error {{no matching function for call to 'invoke'}}
86 invoke(&temp2<>); // expected-error {{no matching function for call to 'invoke'}}
87 invoke(&temp2<int>); // expected-error {{no matching function for call to 'invoke'}}
90 invoke(&temp2<int, void>);
93 invoke(&temp2<int, int>); // expected-error {{no matching function for call to 'invoke'}}