Home | History | Annotate | Download | only in temp.class.spec

Lines Matching refs:Inner

23   template<typename Inner> static int y;
24 template<typename Inner> static int y<Outer>; // expected-warning {{cannot be deduced}} expected-note {{'Inner'}}
25 template<typename Inner> static int y<Inner>; // expected-error {{does not specialize}}
27 template<typename Outer> template<typename Inner> int X<Outer>::y<Outer>; // expected-warning {{cannot be deduced}} expected-note {{'Inner'}}
28 template<typename Outer> template<typename Inner> int X<Outer>::y<Inner>; // expected-error {{does not specialize}}
33 template<typename Inner> static int y;
35 template<> template<typename Inner> int Y<int>::y<Inner>; // expected-error {{does not specialize}}