Home | History | Annotate | Download | only in docs

Lines Matching refs:to

43     There are a number of circumstances where an application may wish to
54 texture applied to it. If the transition is from beach sand to
55 grass to rocks to snow, the application will store each texture
57 textures to blend at run-time.
62 Several solutions to this problem have been proposed, but they either
68 TEXTURE_2D_ARRAY, is added that functions identically to TEXTURE_3D in
153 "<zoffset>" to include layers of an array texture.)
155 Additions to Chapter 2 of the OpenGL 2.0 Specification (OpenGL Operation)
159 Additions to Chapter 3 of the OpenGL 2.0 Specification (Rasterization)
163 Change the first paragraph (page 150) to say (spec changes identical to
172 is used to specify a three-dimensional texture image. target must be one
179 Change the fourth paragraph on page 151 to say (spec changes identical
180 to EXT_texture_array):
190 Change the fourth paragraph on page 156 to say (spec changes identical
191 to EXT_texture_array):
199 is used to specify a two-dimensional texture image. target must be one
212 equivalent to calling TexImage3D with corresponding arguments and depth
229 to EXT_texture_array):
246 Change the last paragraph on page 160 to say (spec changes identical
247 to EXT_texture_array):
261 Change the first paragraph (page 166) to say:
264 specified or changed, and when applied to a fragment. Each parameter is
276 Change the first paragraph (page 172) to say:
283 w_s, h_s, and d_s equal to the width, height, and depth of the
291 Change the third paragraph (page 174) to say:
296 Change the fourth paragraph (page 174) to say:
309 Change the third paragraph (page 176) to say (spec changes identical
310 to EXT_texture_array):
318 Change first paragraph to say (spec changes identical to
327 affects the texture image attached to <target>. ..."
331 Change the second paragraph (page 177) to say (spec changes identical
332 to EXT_texture_array):
340 Change the second and third paragraphs (page 179) to say (spec changes
341 identical to EXT_texture_array):
343 "In addition to image arrays for one-, two-, and three-dimensional
356 by TexImage3D called with target set to TEXTURE 3D, no error is
358 component resolutions are set to zero. If the image array would be
359 supported by such a call to TexImage3D, the proxy state values are set
372 Change section (page 180) to say (spec changes identical to
375 "In addition to the default textures TEXTURE_1D, TEXTURE_2D,
382 A texture object is created by binding an unused name to TEXTURE_1D,
388 with <target> set to the desired texture target and <texture> set to
390 comprising all the state values listed in section 3.8.11, set to the
391 same initial values. If the new texture object is bound to TEXTURE_1D,
397 BindTexture may also be used to bind an existing texture object to
400 INVALID_OPERATION is generated if an attempt is made to bind a texture
402 bind is successful no change is made to the state of the bound texture
403 object, and any previous binding to target is broken.
405 While a texture object is bound, GL operations on the target to which
406 it is bound affect the bound object, and queries of the target to which
408 the dimensionality of the target to which a texture object is bound is
416 that access to these initial textures not be lost, they are treated as
421 TEXTURE_2D_ARRAY_EXT respectively while 0 is bound to the corresponding
424 Change second paragraph on page 181 to say (spec changes identical to
427 "... If a texture that is currently bound to one of the targets
433 Change second paragraph on page 182 to say (spec changes identical to
443 Change second through fourth paragraphs (page 188) to say:
448 texture coordinate, clamped to the range [0, 1]. For texture lookups
450 <q> texture coordinate, clamped to the range [0, 1]. Then the
463 Change the first paragraph (page 189) to say:
468 TEXTURE_2D_ARRAY_EXT to enable one-, two-, three-dimensional, cube
484 (mostly add to existing grammar rules)
511 option, the <texTarget> rule is modified to add the texture targets
519 mapping of 4-tuple input vectors to 4-tuple output vectors.
523 references to the desired texture target (i.e., 1D, 2D, 3D, cube map,
526 following function is used to describe the texture sampling in the
558 -- Section 3.11.6.2 "TXP: Project coordinate and map to color"
560 Add to the end of the section:
562 "A program will fail to load if the TXP instruction is used in
565 Additions to Chapter 4 of the OpenGL 2.0 Specification (Per-Fragment Operations)
567 -- Section 4.4.2.3 "Attaching Texture Images to a Framebuffer"
569 Add to the end of the section (spec changes identical to
577 operates identically to FramebufferTexture3DEXT, except that it
580 layer number, and is treated identically to the <zoffset> parameter in
588 the framebuffer attachment state corresponding to <attachment> is
590 FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT is set to <layer>."
594 Add to the end of the list of completeness rules (spec changes
595 identical to EXT_texture_array):
603 Additions to Chapter 5 of the OpenGL 2.0 Specification (Special Functions)
607 Change the first paragraph on page 242 to say (spec changes
608 identical to EXT_texture_array):
618 Additions to Chapter 6 of the OpenGL 2.0 Specification (State and State Requests)
624 identical to EXT_texture_array):
629 then <params> will contain the number of texture layer attached to the
634 Change the first three paragraphs (page 248) to say (spec changes
635 identical to EXT_texture_array):
642 is used to obtain texture images. It is somewhat different from the
644 (or texture face in the case of a cube map texture target name) is to
650 GetTexImage obtains... from the first image to the last for
660 Additions to Appendix A of the OpenGL 2.0 Specification (Invariance)
664 Additions to the AGL/GLX/WGL Specifications
674 If ARB_fragment_program is not supported, the changes to section 3.11
679 If EXT_framebuffer_object is not supported, the changes to section
691 consecutively in memory, with the layer closest to zero specified first.
695 those specific to three-dimensional images, are ignored when compressed
713 (add to table 6.15, p. 276)
719 to TEXTURE_1D_ARRAY
721 to TEXTURE_2D_ARRAY
726 (add to Table 6.32, p. 293)
739 NO. The name is changed to "array texture" to match the
776 (7) How are stacked textures attached to framebuffer objects?
783 (8) How is this extension related to GL_EXT_texture_array?
785 This extension adapats GL_MESAX_texture_stack to the notation,
792 specific to Nvidia hardware, while this extension adds only support
804 ||2007/05/16||0.4||idr||Converted to MESA_texture_array. Brought in line with EXT_texture_array and NV_gpu_program4.||