Home | History | Annotate | Download | only in docs

Lines Matching refs:to

36     wl_display of a Wayland compositor to an EGLDisplay.  Binding a
38 more interfaces in the Wayland protocol to allow clients to create
40 provides a new target for eglCreateImageKHR, to create an EGLImage
44 EGL implementation to define specific wayland requests and events,
80 Additions to the EGL 1.4 Specification:
82 To bind a server side wl_display to an EGLDisplay, call
87 To unbind a server side wl_display from an EGLDisplay, call
93 wl_display bound to EGLDisplay otherwise EGL_TRUE.
96 wl_display bound to the EGLDisplay currently otherwise EGL_TRUE.
100 compositor will have to create one or more EGLImages for the
102 used to first query the wl_buffer texture format using
107 EGL and the compositor should have another way to get the buffer
114 be sampled from each EGLImage and how they map to rgba components
117 how those components map to the rgba value returned by the
124 One plane, samples RGB from the texture to rgb in the
128 One plane, samples RGBA from the texture to rgba in the
134 Three planes, samples Y from the first plane to r in
135 the shader, U from the second plane to r, and V from
136 the third plane to r.
139 Two planes, samples Y from the first plane to r in
140 the shader, U and V from the second plane to rg.
143 Two planes, samples Y from the first plane to r in
144 the shader, U and V from the second plane to g and a.
151 to create the EGLImage for by using the EGL_WAYLAND_PLANE_WL
153 as defined by the buffer format. Writing to an EGLImage created
158 EGL_HEIGHT to query the width and height of the wl_buffer.
167 Add EGL_WAYLAND_PLANE_WL attribute to allow creating an EGLImage