Home | History | Annotate | Download | only in dcl.constexpr

Lines Matching full:variable

134   //  - a definition of a variable of non-literal type
135 NonLiteral nl; // expected-error {{variable of non-literal type 'NonLiteral' cannot be defined in a constexpr function}}
139 // - a definition of a variable of static storage duration
140 static constexpr int n = 123; // expected-error {{static variable not permitted in a constexpr function}}
144 // - a definition of a variable of thread storage duration
145 thread_local constexpr int n = 123; // expected-error {{thread_local variable not permitted in a constexpr function}}
149 // - a definition of a variable for which no initialization is performed
164 // expected-error@-2 {{variable declaration in a constexpr function is a C++1y extension}}
171 // expected-error@-2 {{variable declaration in a constexpr function is a C++1y extension}}
178 // expected-error@-2 {{variable declaration in a constexpr function is a C++1y extension}}
186 // expected-error@-2 {{variable declaration in a constexpr function is a C++1y extension}}
278 static int value = n; // expected-error {{static variable not permitted}}