Lines Matching defs:int
14 NonLiteral(int) {}
18 explicit Literal(int); // expected-note 2 {{here}}
19 operator int() const { return 0; }
25 constexpr S(int, N::C) {}
26 constexpr S(int, NonLiteral, N::C) {} // expected-error {{constexpr constructor's 2nd parameter type 'NonLiteral' is not a literal type}}
27 constexpr S(int, NonLiteral = 42) {} // expected-error {{constexpr constructor's 2nd parameter type 'NonLiteral' is not a literal type}}
57 int u;
71 typedef int I;
73 using J = int;
74 using K = int[sizeof(I) + sizeof(J)];
85 constexpr V(int(&)[1]) {
86 for (int n = 0; n < 10; ++n)
92 constexpr V(int(&)[2]) {
93 constexpr int a = 0;
98 constexpr V(int(&)[3]) {
99 constexpr int ForwardDecl(int);
104 constexpr V(int(&)[4]) {
110 constexpr V(int(&)[5]) {
116 constexpr V(int(&)[6]) {
122 constexpr V(int(&)[7]) {
132 int n; // expected-note {{member not initialized by constructor}}
136 int a; // expected-note {{member not initialized by constructor}}
151 int h; // expected-note {{member not initialized by constructor}}
160 constexpr AnonMembers(int(&)[1]) : a(), b(), g(), h(), i(), j() {} // ok
162 constexpr AnonMembers(int(&)[2]) : a(), c(), g(), h() {} // expected-error {{constexpr constructor must initialize all members}}
163 constexpr AnonMembers(int(&)[3]) : a(), e(), g(), h(), i(), k() {} // ok
165 constexpr AnonMembers(int(&)[4]) : a(), c(), d(), g(), i() {} // expected-error {{constexpr constructor must initialize all members}}
167 constexpr AnonMembers(int(&)[5]) : a(), g(), h(), i(), k() {} // expected-error {{constexpr constructor must initialize all members}}
169 constexpr AnonMembers(int(&)[6]) {} // expected-error {{constexpr constructor must initialize all members}}
182 template<typename T> using Int = int;
186 int b; // desired-note {{not initialized}}
187 Int<T> c; // desired-note {{not initialized}}
190 int e; // desired-note {{not initialized}}
191 Int<T> f; // desired-note {{not initialized}}
218 constexpr int f(enable_shared_from_this<int>);
242 int a = 0;
243 int b = 2 * a + 1; // ok, not a constant expression.
246 constexpr X(int c) : a(c) {} // ok, b initialized by 2 * c + 1
249 union XU1 { int a; constexpr XU1() = default; }; // expected-error{{not constexpr}}
250 union XU2 { int a = 1; constexpr XU2() = default; };
254 int a;
260 int a = 1;
276 int kGlobal; // expected-note {{here}}
278 constexpr Z(int a) : n(a) {}
280 int n;
286 explicit constexpr Length(int i = 0) : val(i) { }
288 int val;
297 constexpr A(int = 0);
321 int n;
323 int x,
333 constexpr V<int> v; // expected-error {{constant expression}} expected-note {{subobject of type 'int' is not initialized}}
335 constexpr int k = V<int>().x; // FIXME: ok?