Lines Matching full:vertex
104 value: RS_PRIMITIVE_POINT = 0, "Vertex data will be rendered as a series of points"
105 value: RS_PRIMITIVE_LINE = 1, "Vertex pairs will be rendered as lines"
106 value: RS_PRIMITIVE_LINE_STRIP = 2, "Vertex data will be rendered as a connected line strip"
108 value: RS_PRIMITIVE_TRIANGLE_STRIP = 4, "Vertices will be rendered as a connected triangle strip defined by the first three vertices with each additional triangle defined by a new vertex"
109 value: RS_PRIMITIVE_TRIANGLE_FAN = 5, "Vertices will be rendered as a sequence of triangles that all share first vertex as the origin"
112 summary: How to intepret mesh vertex data
114 Describes the way mesh vertex data is interpreted when rendering
270 arg: rs_program_vertex pv, "program vertex object"
755 ret: rs_allocation, "allocation containing vertex data"
757 arg: uint32_t index, "index of the vertex allocation"
759 summary: Return a vertex allocation
762 vertex data, e.g. positions, normals, texcoords
769 ret: uint32_t, "number of allocations in the mesh that contain vertex data"
772 summary: Return the number of vertex allocations
775 vertex data
801 summary: Get the projection matrix for a fixed function vertex program
804 vertex program. Calling this function with a custom vertex shader
815 summary: Load the model matrix for a bound fixed function vertex program
818 vertex program. Calling this function with a custom vertex shader
829 summary: Load the projection matrix for a bound fixed function vertex program
832 vertex program. Calling this function with a custom vertex shader
843 summary: Load the texture matrix for a bound fixed function vertex program
846 vertex program. Calling this function with a custom vertex shader