Home | History | Annotate | Download | only in except.spec

Lines Matching full:with

3 // We permit overriding an implicit exception specification with an explicit one
4 // as an extension, for compatibility with existing code.
13 S::~S() noexcept {} // expected-warning {{function previously declared with an implicit exception specification redeclared with an explicit exception specification}}
14 void S::operator delete(void*) noexcept {} // expected-warning {{function previously declared with an implicit exception specification redeclared with an explicit exception specification}}
23 T::~T() {} // expected-warning {{function previously declared with an explicit exception specification redeclared with an implicit exception specification}}
24 void T::operator delete(void*) {} // expected-warning {{function previously declared with an explicit exception specification redeclared with an implicit exception specification}}
39 // Make sure this restriction interacts properly with __attribute__((noreturn))