Home | History | Annotate | Download | only in strace

Lines Matching refs:fix

121 - Fix FTBFS
168 - build fix for newer kernel headers (#457291)
169 - fix CLONE_VFORK handling (#455078)
175 - fix biarch stat64 decoding (#222275)
176 - fix spurious "..." in printing of environment strings (#358241)
178 - fix hang wait on exited child with exited child (#354261)
179 - fix biarch fork/vfork (-f) tracing (#447475)
180 - fix biarch printing of negative argument kill (#430585)
181 - fix biarch decoding of error return values (#447587)
182 - fix -f tracing of CLONE_VFORK (#455078)
183 - fix ia64 register clobberation in -f tracing (#453438)
185 - fix futex argument decoding (#448628, #448629)
188 - fix multithread issues (#240962, #240961, #247907)
189 - fix spurious SIGSTOP on early interrupt (#240986)
190 - fix utime for biarch (#247185)
191 - fix -u error message (#247170)
193 - fix argv/envp printing with small -s settings, and for biarch
199 - fix -ff -o behavior (#204950, #218435, #193808, #219423)
204 - fix race in child setup under -f (#180293)
214 - Fix ia64 syscall decoding (#206768)
215 - Fix build with glibc-2.4.90-33 and up on all arches but ia64
216 - Fix build against 2.6.18+ headers
219 - Fix bogus decoding of syscalls >= 300 (#201462, #202620).
231 - Fix biarch decoding of socket syscalls (#174354).
232 - Fix biarch -e support (#173986).
234 - Fix ipc syscall decoding (#164755).
241 - Fix setsockopt decoding on 64-bit (#162449).
242 - Fix typos in socket option name strings (#161578).
246 - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
247 - Fix errors detaching from multithreaded process on interrupt (#161919).
248 - Note 4.5.12 fix for crash handling bad signal numbers (#162739).
251 - Fix known syscall recognition for IA32 processes on x86-64 (#158934).
252 - Fix bad output for ptrace on x86-64 (#159787).
253 - Fix potential buffer overruns (#151570, #159196).
262 - Note 4.5.10 select fix (#151570).
265 - Fix select handling on nonstandard fd_set sizes.
267 - Fix initial execve output with -i (#143365).
271 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
272 - fix -e signal=NAME parsing (#143362)
273 - fix x86_64 exit_group syscall handling
278 - fix potential crash in getxattr printing
281 - fix multithreaded exit handling (#132150, #135254)
282 - fix ioctl name matching (#129808)
287 - fix clock_* and timer_* argument output (#131420)
323 - revert bogus s390 fix
388 - fix strace -f (Roland McGrath, #68994)
399 - fix for the last patch by Jeff Law (#62591)
457 - fix sigreturn on sparc
460 - fix stat64 misdef (#10485)
473 - fix socketcall on sparc.
476 - fix KERN_SECURELVL compile problem
479 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
515 - fix typo (printf, not tprintf).
518 - fix compile problem on sparc.