Home | History | Annotate | Download | only in api

Lines Matching full:allocation

18 summary: Allocation Data Access Functions
21 an allocation.
37 arg: rs_allocation dstAlloc, "Allocation to copy cells into."
39 arg: uint32_t dstMip, "Mip level in the destination allocation. 0 if mip mapping is not used."
41 arg: rs_allocation srcAlloc, "Source allocation."
43 arg: uint32_t srcMip, "Mip level in the source allocation. 0 if mip mapping is not used."
46 Copies the specified number of cells from one allocation to another.
49 the same allocation yields undefined results.
52 of either allocation. Be careful!
66 arg: rs_allocation dstAlloc, "Allocation to copy cells into."
69 arg: uint32_t dstMip, "Mip level in the destination allocation. 0 if mip mapping is not used."
70 arg: rs_allocation_cubemap_face dstFace, "Cubemap face of the destination allocation. Ignored for allocations that aren't cubemaps."
73 arg: rs_allocation srcAlloc, "Source allocation."
76 arg: uint32_t srcMip, "Mip level in the source allocation. 0 if mip mapping is not used."
77 arg: rs_allocation_cubemap_face srcFace, "Cubemap face of the source allocation. Ignored for allocations that aren't cubemaps."
80 Copies a rectangular region of cells from one allocation to another.
84 the same allocation yields undefined results.
87 exceeds the size of its respective allocation. Be careful!
103 arg: rs_allocation a, "Allocation to get the data from."
104 arg: uint32_t x, "X offset in the allocation of the first cell to be copied from."
105 summary: Get a vector from an allocation of scalars
107 This function returns a vector composed of successive cells of the allocation.
108 It assumes that the allocation contains scalars.
123 the X index, exceeding the size of the allocation, or using indices incompatible
124 with the dimensionality of the allocation yields undefined results.
137 arg: uint32_t y, "Y offset in the allocation of the first cell to be copied from."
149 arg: uint32_t z, "Z offset in the allocation of the first cell to be copied from."
158 arg: rs_allocation a, "Allocation to store the data into."
160 arg: uint32_t x, "X offset in the allocation of the first cell to be copied into."
161 summary: Store a vector into an allocation of scalars
163 This function stores the entries of a vector into successive cells of an allocation.
164 It assumes that the allocation contains scalars.
178 X index, exceeding the size of the allocation, or using indices incompatible
179 with the dimensionality of the allocation yiels undefined results.
193 arg: uint32_t y, "Y offset in the allocation of the first cell to be copied into."
206 arg: uint32_t z, "Z offset in the allocation of the first cell to be copied into."
214 summary: Return a cell from an allocation
216 This function extracts a single cell from an allocation.
356 summary: Get the U component of an allocation of YUVs
358 Extracts the U component of a single YUV value from a 2D allocation of YUVs.
360 Inside an allocation, Y, U, and V components may be stored if different planes
374 summary: Get the V component of an allocation of YUVs
376 Extracts the V component of a single YUV value from a 2D allocation of YUVs.
378 Inside an allocation, Y, U, and V components may be stored if different planes
392 summary: Get the Y component of an allocation of YUVs
394 Extracts the Y component of a single YUV value from a 2D allocation of YUVs.
396 Inside an allocation, Y, U, and V components may be stored if different planes
407 arg: rs_allocation a, "Allocation to sample from."
410 summary: Sample a value from a texture allocation
412 Fetches a value from a texture allocation in a way described by the sampler.
414 If your allocation is 1D, use the variant with float for location. For 2D,
456 summary: Set a cell of an allocation
458 This function stores a value into a single cell of an allocation.