Home | History | Annotate | Download | only in api

Lines Matching refs:Index

52  cell, like the Array0 index or the current level of detail.
61 field: uint32_t xStart, "Starting index in the X dimension."
62 field: uint32_t xEnd, "Ending index (exclusive) in the X dimension."
63 field: uint32_t yStart, "Starting index in the Y dimension."
64 field: uint32_t yEnd, "Ending index (exclusive) in the Y dimension."
65 field: uint32_t zStart, "Starting index in the Z dimension."
66 field: uint32_t zEnd, "Ending index (exclusive) in the Z dimension."
67 field: uint32_t arrayStart, "Starting index in the Array0 dimension."
68 field: uint32_t arrayEnd, "Ending index (exclusive) in the Array0 dimension."
69 field: uint32_t array1Start, "Starting index in the Array1 dimension."
70 field: uint32_t array1End, "Ending index (exclusive) in the Array1 dimension."
71 field: uint32_t array2Start, "Starting index in the Array2 dimension."
72 field: uint32_t array2End, "Ending index (exclusive) in the Array2 dimension."
73 field: uint32_t array3Start, "Starting index in the Array3 dimension."
74 field: uint32_t array3End, "Ending index (exclusive) in the Array3 dimension."
200 the index space specified in options. With the index space explicitly specified
236 summary: Index in the Array0 dimension for the specified kernel context
238 Returns the index in the Array0 dimension of the cell being processed, as specified
242 over and rarely used indices, like the Array0 index.
247 &nbsp;&nbsp;// The current index in the common x, y, z dimensions are accessed by<br/>
262 summary: Index in the Array1 dimension for the specified kernel context
264 Returns the index in the Array1 dimension of the cell being processed, as specified
275 summary: Index in the Array2 dimension for the specified kernel context
277 Returns the index in the Array2 dimension of the cell being processed,
289 summary: Index in the Array3 dimension for the specified kernel context
291 Returns the index in the Array3 dimension of the cell being processed, as specified
391 over and rarely used indices, like the Array0 index.
450 summary: Index in the Levels of Detail dimension for the specified kernel context
452 Returns the index in the Levels of Detail dimension of the cell being processed,