Home | History | Annotate | Download | only in temp.explicit

Lines Matching refs:member

9 // A definition of the class or class template containing a member function 
11 // the member function template.
18 // A definition of a class template or class member template shall be in scope
20 // member template.
34 // explicit instantiation of a member function or a static data member of the
39 template int X1<int>::member; // expected-error {{undefined template}}
41 // A definition of a member class of a class template shall be in scope at the
42 // point of an explicit instantiation of the member class.
43 template struct X2<float>::InnerClass; // expected-error{{undefined member}}
46 // special member function (Clause 12), the program is ill-formed.
54 // instantiate a member of the class template which itself is not yet defined.