Home | History | Annotate | Download | only in dcl.constexpr

Lines Matching defs:NonLiteral

12 struct NonLiteral { // expected-note 3{{no constexpr constructors}}
13 NonLiteral() {}
14 NonLiteral(int) {}
30 struct T : SS, NonLiteral {
42 constexpr NonLiteral NonLiteralReturn() const { return {}; } // expected-error {{constexpr function's return type 'NonLiteral' is not a literal type}}
48 typedef NonLiteral F() const;
52 constexpr int NonLiteralParam(NonLiteral) const { return 0; } // expected-error {{constexpr function's 1st parameter type 'NonLiteral' is not a literal type}}
53 typedef int G(NonLiteral) const;
139 NonLiteral nl; // expected-error {{variable of non-literal type 'NonLiteral' cannot be defined in a constexpr function}}
186 NonLiteral nl;
187 constexpr NonLiteral &ExternNonLiteralVarDecl() {
188 extern NonLiteral nl;