Home | History | Annotate | Download | only in except.spec

Lines Matching defs:Throw

8   virtual ~X0() throw(A); // expected-note{{overridden virtual function is here}} 
11 virtual ~X1() throw(B); // expected-note{{overridden virtual function is here}}
17 CA0 &operator=(const CA0&) throw(A);
20 CA1 &operator=(const CA1&) throw(B);
25 CA2 &(CA2::*captr1)(const CA2&) throw(A, B) = &CA2::operator=;
26 CA2 &(CA2::*captr2)(const CA2&) throw(A, B, C) = &CA2::operator=;
27 CA2 &(CA2::*captr3)(const CA2&) throw(A) = &CA2::operator=; // expected-error{{target exception specification is not superset of source}}
28 CA2 &(CA2::*captr4)(const CA2&) throw(B) = &CA2::operator=; // expected-error{{target exception specification is not superset of source}}
36 int inClassInit = (throw B(), 0);
40 static_assert(noexcept(IC0()), "IC0() does not throw");
61 // These both perform a move, but that copy might throw, because it calls
121 Base(X<2>) throw(X<2>);
122 template<typename T> Base(T) throw(T);
124 template<typename T> struct Throw {
125 Throw() throw(T);
127 struct Derived : Base, Throw<X<3>> {
129 Throw<X<4>> x;
132 friend Derived::Derived(X<0>) throw(X<3>, X<4>);
134 friend Derived::Derived(X<2>) throw(X<2>, X<3>, X<4>);