Home | History | Annotate | Download | only in api

Lines Matching full:sphere

126 arg: float4* sphere, "float4 representing the sphere."
133 summary: Checks if a sphere is within the frustum planes
135 Returns true if the sphere is within the 6 frustum planes.
137 float distToCenter = dot(left->xyz, sphere->xyz) + left->w;
138 if (distToCenter < -sphere->w) {
141 distToCenter = dot(right->xyz, sphere->xyz) + right->w;
142 if (distToCenter < -sphere->w) {
145 distToCenter = dot(top->xyz, sphere->xyz) + top->w;
146 if (distToCenter < -sphere->w) {
149 distToCenter = dot(bottom->xyz, sphere->xyz) + bottom->w;
150 if (distToCenter < -sphere->w) {
153 distToCenter = dot(near->xyz, sphere->xyz) + near->w;
154 if (distToCenter < -sphere->w) {
157 distToCenter = dot(far->xyz, sphere->xyz) + far->w;
158 if (distToCenter < -sphere->w) {
169 arg: float4* sphere